Задать вопрос
22 июня, 21:23

Составьте и выполните программу решения задачи:

Если между цифрами двузначного числа записать ноль, то полученное трехзначное число

будет в 7 раз больше первоначального. Найдите это число.

Паскаль

+2
Ответы (2)
  1. 23 июня, 00:01
    0
    Вариант без строк.

    //Pascal

    var tmp1, tmp2, i: integer;

    begin

    for i : = 10 to 99 do

    begin

    tmp1 : = 0; tmp2 : = 0;

    tmp1 : = (i div 10) * 100;

    tmp2 : = i mod 10;

    tmp2 : = tmp1 + tmp2;

    if tmp2 = i*7 then writeln ('Найдено число = ', i) ;

    end;

    readln;

    end.

    Результат:

    Найдено число = 15
  2. 23 июня, 00:26
    0
    Если между цифрами двузначного числа записать ноль, то полученное трехзначное число

    будет в 7 раз больше первоначального. Найдите это число.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте и выполните программу решения задачи: Если между цифрами двузначного числа записать ноль, то полученное трехзначное число будет в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
На паскале нужно решить задачи 1. Задано трехзначное число. Составьте программу, с помощью которой определите произведение кубов цифр этого числа. 2. Задано трехзначное число.
Ответы (1)