Задать вопрос
10 августа, 17:51

Дан целочисленный двумерный массив, равномерности m x n, найти сумму всех элементов массива

+1
Ответы (1)
  1. 10 августа, 21:05
    0
    Var

    mas : array [1 ... 100,1 ... 100] of integer;

    n, m, i, j, summa:integer;

    begin

    write ('Введите количество строк n=') ; readln (n) ;

    write ('Введите количество столбцов m=') ; readln (m) ;

    for i:=1 to n do

    for j:=1 to m do

    mas[i, j]:=random (99) ;

    writeln ('Исходная матрица') ;

    for i:=1 to n do

    begin

    for j:=1 to m do

    write (mas[i, j]:2,' ') ;

    writeln;

    end;

    summa:=0;

    for i:=1 to n do

    for j:=1 to m do

    summa:=summa+mas[i, j];

    write ('Сумма=', summa) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан целочисленный двумерный массив, равномерности m x n, найти сумму всех элементов массива ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)