Задать вопрос
10 июня, 06:43

Помогите составить программу в паскале! Известна стоимость 1 кг конфет, печенья, яблок. Найти стоимость всей покупки, если купили х кг конфет, y кг печенья и z кг яблок.

+4
Ответы (1)
  1. 10 июня, 08:01
    0
    Var

    k, p, i, s, x, y, z:real;

    begin

    write ('Стоимость килограмма конфет: ') ;

    readln (k) ;

    write ('Стоимость килограмма печенья: ') ;

    readln (p) ;

    write ('Стоимость килограмма яблок: ') ;

    readln (i) ;

    write ('Купили конфет: ') ;

    readln (x) ;

    write ('Купили печенья: ') ;

    readln (y) ;

    write ('Купили яблок: ') ;

    readln (z) ;

    s:=x*k+y*p+z*i;

    write ('Потратили всего: ', s) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите составить программу в паскале! Известна стоимость 1 кг конфет, печенья, яблок. Найти стоимость всей покупки, если купили х кг ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделайте программу паскаль АВС 1) Даны стороны треугольника. Найти его периметр. 2) Известна стоимость 1 кг конфет, печенья и яблок. Найти стоимость всей покупки, если купили х кг конфет, у кг печенья и z кг яблок.
Ответы (2)
Известна стоимость 1 кг конфет, 2 кг печенья, 1 кг яблок. Подсчитать стоимость покупки, если купили 3 кг. конфет, 4 кг. яблок, 2 кг печенья.
Ответы (1)
Дана программа program appl; var c, v: real; {цена и вес яблок} st: real; {стоимость покупки} begin writeln ('Вычисление стоимости покупки.') ; writeln ('введите исходные данные:') ; write ('Цена 1 кг яблок (руб.
Ответы (1)
Составить программу вычисления стоимости покупки с учётом скидки. Скидка в 10% предоставляется, если сумма покупки больше 1000 рублей.
Ответы (1)
Составить программу вычисления стоимости покупки с учётом скидки. Скидка 3% предоставляется в том случае, если сумма покупки больше 500 рублей, 5% - если сумма больше 1000 рублей.
Ответы (1)