Задать вопрос
29 октября, 03:54

Дано массив A [1 ... n]. Сложить программу подсчета средних арифметических всех отрицательных и всех положительных его чисел

+4
Ответы (1)
  1. 29 октября, 06:01
    0
    var a: array[1 ... 999] of integer;

    n, sp, so, kp, ko: integer;

    begin

    read (n) ;

    for var i : = 1 to n do begin

    a[i] : = random (-9, 9) ;

    write (a[i], ' ') ;

    if a[i] > 0 then begin

    sp + = a[i];

    kp + = 1;

    end;

    if a[i] < 0 then begin

    so + = a[i];

    ko + = 1;

    end;

    end;

    writeln;

    writeln ('Среднее арифметическое положительных чисел = ', sp/kp) ;

    writeln ('Среднее арифметическое отрицательных чисел = ', so/ko) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано массив A [1 ... n]. Сложить программу подсчета средних арифметических всех отрицательных и всех положительных его чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
Напишите программу на Паскале. Дан массив положительных и отрицательных чисел. Вычислить сумму положительных и произведение отрицательных чисел. А[1 ... 10]
Ответы (1)
Дано массив с N положительных и отрицательных чисел. а) найти среднее аримфметичкое отдельно для положительных, среднее геометрическое - для негативных. б) найти максимальную по длинне последовательность чисел с одинаковым знаком.
Ответы (1)
1. Разработать программу алгоритма для подсчета количества отрицательных чисел среди целых чисел a, b, c. Протестировать алгоритм для всех возможных случаев (когда количество отрицательных чисел равно 0, 1, 2 и 3). 2.
Ответы (1)