Задать вопрос
15 февраля, 23:09

Знак числа (C++).

Для данного числа x выведите значение sign (x). Например, при x=179 программа должна вывести 1.

Формат входных данных:

В программу вводится вещественное число x (-100000 ≤ x ≤ 100000), заданное с двумя знаками после десятичной точки.

Формат выходных данных:

Программа должна вывести - 1, 0 или 1.

+1
Ответы (1)
  1. 16 февраля, 00:08
    0
    Int main ()

    {

    int x;

    std::cin >>x;

    if x>0 std::cout << "1" else

    if x<0 std::cout << "-1" else

    std::cout << "0";

    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Знак числа (C++). Для данного числа x выведите значение sign (x). Например, при x=179 программа должна вывести 1. Формат входных данных: В ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В математике функция sign (x) (знак числа) определена так: sign (x) = 1, если x > 0, sign (x) = - 1, если x < 0, sign (x) = 0, если x = 0. Для данного числа x выведите значение sign (x). Ввод 179 Вывод 1
Ответы (1)
Написать программу в Паскале. По заданному числу N определите знак числа. Формат входных данных: Во входном файле input.
Ответы (1)
По данному числу n вычислите сумму 2 (1-1/3+1/5-1/7 + ... + (-1) n / (2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000. Формат выходных данных: Необходимо вывести значение выражения
Ответы (1)
Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N. Формат входных данных Задано единственное число N. Формат выходных данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.
Ответы (1)
Дано натуральное трёхзначное число n. Найдите сумму и произведение цифр в нём. Формат входных данных Вводится целое число n (100≤n≤999) Формат выходных данных Требуется вывести сумму и произведение его цифр через пробел.
Ответы (1)