Задать вопрос
19 ноября, 01:18

Создайте программу в паскале, которая будет выводить на экран числовой ряд из 10 элементов, начиная с цифры 2, каждый элемент должен быть в 2 раза предыдущего.

должно работать так:

Окно вывода:

2 4 8 16 32 64 128 256 512 1024

+1
Ответы (1)
  1. 19 ноября, 02:52
    0
    Var a, i:integer;

    begin

    a:=1;

    for i:=1 to 10 do

    begin

    a:=a*2;

    write (a,' ') ;

    end;

    end.

    Результат:

    2 4 8 16 32 64 128 256 512 1024
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Создайте программу в паскале, которая будет выводить на экран числовой ряд из 10 элементов, начиная с цифры 2, каждый элемент должен быть в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Cоставить алгоритм и программу для: 1) Заполнения лвумерного массива (6x4) произвольными значениями и вывода его на экран! 2) Подсчета произведения элементов по строкам и вывода на экран номеров строк и соответствующих произведений элементов!
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Дан двухмерный массив m*n случайных целых чисел, которые должны генерироваться в диапазоне [-5, 7], где 1 ≤ т ≤ 9, 1 ≤ n ≤ 10.
Ответы (1)