Задать вопрос
12 января, 16:15

найти большее из 4-ёх чисел pascal ABC NET

+2
Ответы (1)
  1. 12 января, 19:15
    0
    Function min2 (var a, b:integer) : integer;

    begin

    if a>b then

    result:=a

    else

    result:=b;

    end;

    function min4 (var a, b, c, d:integer) : integer;

    begin

    if min2 (a, b) >min2 (c, d) then

    result:=min2 (a, b)

    else

    result:=min2 (c, d) ;

    end;

    var a, b, c, d: integer;

    begin

    readln (a, b, c, d) ;

    writeln (min4 (a, b, c, d)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «найти большее из 4-ёх чисел pascal ABC NET ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
Задача в pascal abc net: Вычислить произведение с помощью цикла "До (repeat) " (3+f) * (6+f) * (9+f) * ... * (27+f)
Ответы (1)