Задать вопрос
12 января, 07:21

Информатика:

Миша плавал в бассейне размером N*M метров и устал. В этот момент он обнаружил, что находится на расстоянии х метров от одного из длинных бортиков. (не обязательно от ближайших) и y метров от одного из коротких бортиков. Какое минимальное расстояние должен проплыть миша что бы выбраться из бассейна на бортик. Формат вход данных

Вводятся 4 натуральных числа: M, N, x, y (N≠M), разделенные пробелами. Все числа не превосходят 100 Формат выходных данных. требуется вывести 1 число-минимальное расстояние которое должен проплыть миша что бы выбраться на бортик

Вход:

10,25,7,3

Выход:

3

+3
Ответы (1)
  1. 12 января, 11:21
    0
    Var m, n, x, y, h, m1, m2, min:integer;

    begin

    readln (m, n, x, y) ;

    if m>n then begin h:=m; m:=n; n:=h; end;

    if m-x
    if n-y
    if m1
    writeln (min) ;

    end.

    Пример:

    10 25 7 3

    3
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Информатика: Миша плавал в бассейне размером N*M метров и устал. В этот момент он обнаружил, что находится на расстоянии х метров от одного ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С некоторого момента прошло N дней. Сколько полных недель прошло за этот период. Формат входных данных На вход программе подается 0≤N≤106. Формат выходных данных Вывести целое число - ответ на вопрос. Примеры: Вход 100 Выход 14
Ответы (1)
Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N. Формат входных данных Задано единственное число N. Формат выходных данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.
Ответы (1)
Дано натуральное трёхзначное число n. Найдите сумму и произведение цифр в нём. Формат входных данных Вводится целое число n (100≤n≤999) Формат выходных данных Требуется вывести сумму и произведение его цифр через пробел.
Ответы (1)
Напишите рекурсивную функцию вычисления суммы цифр натурального числа. Формат входных данных На вход ваша программа получает одно натуральное число n (n
Ответы (1)
Дан массив из n элементов. Необходимо определить, есть ли в данном массиве элемент, равный заданному числу k ? Если есть, то вывести номер первого его вхождения. Формат входных данных С клавиатуры вводится натуральное число n (n≤100).
Ответы (1)