Задать вопрос
26 мая, 08:17

Даны 5 чисел (могут быть и отрицательные и положительные), вывести нечетные числа, которые меньше нуля.

Написать программу Pascal ABC

+2
Ответы (1)
  1. 26 мая, 09:48
    0
    Var a, b, c, d, e:integer;

    begin

    readln (a, b, c, d, e) ;

    if (a mod 20) and (a<0) then write (a) ;

    if (b mod 20) and (b<0) then write (' ', b) ;

    if (c mod 20) and (c<0) then write (' ', c) ;

    if (d mod 20) and (d<0) then write (' ', d) ;

    if (e mod 20) and (e<0) then write (' ', e) ;

    end.

    Пример:

    -15 42 - 10 27 - 79

    -15 - 79
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны 5 чисел (могут быть и отрицательные и положительные), вывести нечетные числа, которые меньше нуля. Написать программу Pascal ABC ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Pascal. Тема: Циклы С клавиатуры вводится целое произвольное число 1) Вывести на экран первую и последнюю цифру числа. 2) Вывести на экран наибольшую цифру числа 3) Вывести на экран нечетные цифры этого числа
Ответы (2)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)