Задать вопрос
3 января, 10:28

Напишите программу, которая подсчитает сумму натуральных чисел от 1 до n

+3
Ответы (1)
  1. 3 января, 14:14
    0
    Var i, n, s:integer;

    begin

    write ('Введите n: ') ;

    readln (n) ;

    for i:=1 to n do

    s:=s+i;

    writeln ('Сумма всех чисел от 1 до ', n,' равна ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая подсчитает сумму натуральных чисел от 1 до n ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая подсчитает сумму натуральных чисел от 1 до n Вот пример из задачи: Написать пр-му, которая выводит все натуральные числа от 1 до n Program zd; var i, n: integer; Begin Writeln ('Введите n') ; readln (n) ;
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Напишите программу, которая подсчитает, сколько существует двузначных положительных чисел сумма цифр которых не превышает 15 (Паскаль). Нужно написать программу используя div и mod, без string и прочего!
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1) Напишите программу, которая вводит натуральное число N и нахо дит сумму всех натуральных чисел от 1 до N. Используйте сначала цикл с условием, а потом - цикл с переменной.
Ответы (1)