Задать вопрос
25 февраля, 09:41

Напишите программу, которая подсчитает сумму натуральных чисел от 1 до n

Вот пример из задачи:

Написать пр-му, которая выводит все натуральные числа от 1 до n

Program zd;

var i, n: integer;

Begin

Writeln ('Введите n') ;

readln (n) ;

for i:=i to n do

begin

writeln (i,' ') ;

end;

end.

+2
Ответы (1)
  1. 25 февраля, 12:06
    0
    Program n1;

    var n, sum, i: integer;

    begin

    readln (n) ;

    sum:=0;

    for i:=1 to n do sum:=sum+i;

    write ('сумма: ', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая подсчитает сумму натуральных чисел от 1 до n Вот пример из задачи: Написать пр-му, которая выводит все ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)
Почему программа не работает (Pascal) Program abc; Var A, B: array [1 ... 5] of integer; i:integer; begin For i : = 1 to 5 do begin writeln ('введите A') ; readln (A[i]) ; writeln ('Введите B') ; readln (B[i]) ; writeln (A[1]+B[1]) ;
Ответы (1)
Запиши программу в Паскале для вычисления площади прямоугольника со сторонами c и m. 1) begin writeln ('Введи длину и ширину прямоугольника c и m') ; readln (c, m) ; s:=c*m; writeln ('s=', s) ; readln; end.
Ответы (1)
Program a2; var n, i, min, max, x:integer; begin Writeln ('Введите колицество человек в классе:') ; Readln (n) ; Writeln ('Введите рост 1 ученика:') ; readln (x) ; min:=x; max:=x; for i:=2 to n do begin Writeln ('Введите рост ', i,' ученика:') ;
Ответы (1)
Помогите объяснить задачу! Program String29; var otvet:String; i:integer; S0, S:String; C:char; begin Writeln ('Введите строкy S') ; readln (S) ; Writeln ('Введите строкy S0') ; readln (S0) ; Writeln ('Введите символ C') ; readln (C) ;
Ответы (1)