Задать вопрос
22 ноября, 23:51

Написать программу, которая находит сумму всех цифр введенного с клавиатуры четырехзначного числа

+1
Ответы (1)
  1. 23 ноября, 01:19
    0
    Var

    a, sum:integer;

    begin

    Read (a) ;

    while (a > 0) do begin

    sum + = a mod 10;

    a : = a div 10;

    end;

    Writeln (sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая находит сумму всех цифр введенного с клавиатуры четырехзначного числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них. Пример: Введите два числа: 1 5 Наименьшее число 1 Наибольшее число 5 Уровень B.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
1. Напишите программу, которая выводит на экран все простые числа в диапазоне от 1 до числа, введенного с клавиатуры. 2. Напишите функцию, которая находит наибольший общий делитель для двух заданных чисел.
Ответы (1)
Напишите программу, которая выводит на экран все простые числа в диапазоне от 1 до числа, введенного с клавиатуры. Напишите функцию, которая находит наибольший общий делитель для двух заданных чисел.
Ответы (1)