Задать вопрос
12 августа, 09:17

Есть координаты вершин треугольника. Определить, где находится начало координат (внутри треугольника, снаружи или находится на одной из его сторон) Для Паскаля ABC, подскажите самый простой способ кода ...

+3
Ответы (1)
  1. 12 августа, 10:29
    0
    type TXY = record x, y: Real end;

    function sqt (a, b, c: TXY) : Real;

    begin

    sqt:=abs ((a. x-b. x) * (c. y-b. y) - (a. y-b. y) * (c. x-b. x)) / 2;

    end;

    const

    eps=1e-4;

    o: TXY = (x:0; y:0) ;

    var a, b, c: TXY;

    s1, s2, s3: Real;

    begin

    Write ('Введите координаты вершин треугольника: ') ;

    ReadLn (a. x, a. y, b. x, b. y, c. x, c. y) ;

    s1:=sqt (o, a, b) ; s2:=sqt (o, b, c) ; s3:=sqt (o, a, c) ;

    Write ('Центр координат лежит ') ;

    if abs (s1)
    else if abs (s2)
    else if abs (s3)
    else if abs (s1+s2+s3-sqt (a, b, c))
    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Есть координаты вершин треугольника. Определить, где находится начало координат (внутри треугольника, снаружи или находится на одной из его ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Злой хакер хочет испортить программное обеспечение на 40 компьютерах компании. На каждом компьютере 37 программ, каждая из которых состоит из 9000 строк кода.
Ответы (2)
Прямоугольник. Зная координаты трех вершин прямоугольника на координатной плоскости, определить координаты четвертой вершины. Входные данные В одной строке записаны шесть чисел - координаты трех вершин прямоугольника.
Ответы (1)
1. (x делится без остатка на 2 и на 3) записать на языке паскаля. 2. (х не делится на 5) записать на языке паскаля. 3. (величина х не кратна 3) записать на языке паскаля.
Ответы (1)
написать программу на языке Паскаля. Заданы координаты двух точек. Определите, расположены ли они на одной окружности с центром в начале координат. Результат присвоить символьной переменной.
Ответы (1)
С + + Помогите! Вася работает программистом и получает 50$ за каждые 100 строк кода. За каждое третье опоздание Васю штрафуют на 20$.
Ответы (1)