Задать вопрос
8 декабря, 01:17

написать программу на языке Паскаля. Заданы координаты двух точек. Определите, расположены ли они на одной окружности с центром в начале координат. Результат присвоить символьной переменной. Две точки находятся на одной окружности, если длины радиус-векторов, соединяющих эти точки с началом координат, равны (проверку на равенство осуществить с точностью до е=1.0 Е-3)

+3
Ответы (1)
  1. 8 декабря, 05:15
    0
    var x1, x2, y1, y2:real;

    a:string;

    begin

    readln (x1, y1) ;

    readln (x2, y2) ;

    if abs (x1/y1) = abs (x2/y2) then a:='Na odnoi okrujnosti' else a:='Ne na odnoi okrujnosti';

    writeln (a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «написать программу на языке Паскаля. Заданы координаты двух точек. Определите, расположены ли они на одной окружности с центром в начале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан алгоритм: Начало Присвоить a значение 1 Присвоить b значение 1 Присвоить c значение 0 Пока a меньше чем 1001 Начало цикла Присвоить b значение b * a Присвоить a значение a + 1 Конец цикла Пока b делится на 6 Начало цикла Присвоить c значение c +
Ответы (1)
Даны две числовые переменные a и b. Необходимо присвоить переменной a значение переменной b, переменной b необходимо присвоить значение переменной a, без использования дополнительных переменных.
Ответы (1)
Запишите на алгоритмическом языке алгоритм, в результате которого переменной A будет присвоено значение переменной B, переменной B-значение переменной C, а переменной C-значение переменной A. Используйте не более одной промежуточной переменной.
Ответы (1)
Даны две переменные целого типа: A и B. Если их значения не равны, то присвоить каждой переменной максимальное из этих значений, а если равны, то присвоить переменным нулевые значения.
Ответы (1)
Даны 2 переменные целого типа а и в если их значения не равны, то присвоить каждой переменной сумму этих значений, а если равны, то присвоить пременным нулевые значения. вывести новые значения а и в
Ответы (1)