Задать вопрос
15 октября, 00:15

Даны три переменные a b c. составить алгоритм который если все они равны выдает об этом сообщение, а в противном случае уменьшает их на 5

+5
Ответы (1)
  1. 15 октября, 00:53
    0
    Var a, b, c: integer;

    begin

    readln (a, b, c) ;

    if (a=b) and (b=c) then writeln ('Все числа равны')

    else

    begin

    a:=a-5; b:=b-5; c:=c-5;

    writeln ('a = ', a,' b = ', b,' c = ', c) ;

    end;

    end.

    Пример:

    7 5 6

    a = 2 b = 0 c = 1
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны три переменные a b c. составить алгоритм который если все они равны выдает об этом сообщение, а в противном случае уменьшает их на 5 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны 3 переменные, составить программу: если все они =; выдает сообщение: переменные=, в противном случае каждую из них увеличь на 10
Ответы (1)
Помогите сделать программу в Паскале В котором 1) Программа выдает сообщение "Вы маль или дево" 2) Пользователь в переменную ST1 задает значение маль или дево 3) Программа выдает сооб "Ты пошла бы играть в куклы" 4) Вводить ответ через переменную
Ответы (1)
1. раздели на 2 2. вычти 1 Первая из них уменьшает число на экране в 2 раза, вторая уменьшает его на 1. Исполнитель работает только с натуральными числами. Составьте алгоритм получения из числа 65 числа 4, содержащий не более 5 команд.
Ответы (1)
Некоторый алгоритм из одной цепочки десятичных цифр получает новую цепочку следующим образом. Сначала вычисляется сумма всех цифр в цепочке. Если сумма является нечетным числом, к цепочке справа дописывается цифра 1, в противном случае - цифра 0.
Ответы (1)
Составить блок схему и листинг программы Даны три переменные: X, Y, Z. Если их значения упорядочены по убыванию, то удвоить их; в противном случае заменить значение каждой переменной на противоположное.
Ответы (1)