Задать вопрос
21 октября, 11:27

Решить в паскале

В первый день рабочий произвел х деталей. Во второй и в последующие дни он увеличивал норму предыдущего дня в 2 раза. Сколько деталей он делал каждый день данной недели?

+3
Ответы (1)
  1. 21 октября, 12:23
    0
    Var x, i:integer;

    begin

    readln (x) ;

    for i:=2 to 7 do

    begin

    x:=2*x;

    writeln (i,': ', x) ;

    end;

    end.

    Пример:

    2

    2: 4

    3: 8

    4: 16

    5: 32

    6: 64

    7: 128
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить в паскале В первый день рабочий произвел х деталей. Во второй и в последующие дни он увеличивал норму предыдущего дня в 2 раза. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. Какой суммарный путь пробежит спортсмен за 7 дней? Составить программу в паскале помощью цикла repeat.
Ответы (2)
Нужно в паскале ABS Начав тренировки спортсмен в первый день пробежал 10 км. Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. Какой суммарный путь пробежит спортсмен за 7 дней?
Ответы (1)
Начав тренировки, спортсмен пробежал в первый день 10 км. Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. Сколько он пробегал за каждый день тренировки? Какой суммарный путь пробежит спортсмен за 7 дней?
Ответы (1)
1) Написать программу, которая выводит сумму всех чисел, кратных 3 от 3 до 3000. 2) Написать программу на Паскале. Бегун в первый день пробежал 5 км. Каждый следущий день он увеличивал длину пробега на 10% от предыдущего дня.
Ответы (1)
Turbo Pascal. Спортсмен пробежал 10 км в первый день. Каждый следующий день он увеличивал норму на 10% от нормы предыдущего дня. Определить: a) Через сколько дней он будет пробегать не более 20 км? б) Сколько километров он пробежит на 7-ой день?
Ответы (1)