Задать вопрос
21 октября, 02:51

Тема массивы, язык паскаль.

Составьте программу которая заменяет все числа кратные 9 на - 5 (Массив задается с клавиатуры, количество элементов 12)

+4
Ответы (1)
  1. 21 октября, 03:41
    0
    Program z1;

    var a:array[1 ... 12] of integer;

    i:integer;

    begin

    for i:=1 to 12 do

    begin

    readln (a[i]) ;

    if a[i] mod 9 = 0 then a[i]:=-5;

    end;

    for i:=1 to 12 do writeln (a[i]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Тема массивы, язык паскаль. Составьте программу которая заменяет все числа кратные 9 на - 5 (Массив задается с клавиатуры, количество ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Тема массивы, язык паскаль. Составьте программу которая меняет местами первый и девятый элементы массива (Массив задается с клавиатуры, количество элементов 17)
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Составьте программу, которая формирует массив из 15 случайных чисел вдиапазоне от 15 до - 15 и: 1) отрицательные числа заменяет наих модули, а неотрицательные возводит в квадрат 2) четные числа заменяет на 2, а от нечетных - отнимает 5 3) числа,
Ответы (1)