Задать вопрос
31 мая, 17:27

Задача А

Число Фибоначчи это числовая последовательность, в которой первые два числа единицы, а каждое последующее равно сумме двух предыдущих. Дано натуральное число N (2< N < 2*10^9). Найти два ближайших к нему числа Фибоначчи. Одно из них меньше N, другое больше N. Вывести их в порядке возрастания. Входные данные:

В первой строке входного файла Input. txt содержится одно натуральное число N.

Выходные данные:

В выходной файл Output. txt вывести два ближайших к N числа Фибоначчи.

+5
Ответы (1)
  1. 31 мая, 19:07
    0
    Var

    a, b, n:integer;

    begin

    read (n) ;

    a : = 0;

    b : = 1;

    while b < n do

    begin

    b : = a + b;

    a : = b - a;

    end;

    write (a,' ', b)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача А Число Фибоначчи это числовая последовательность, в которой первые два числа единицы, а каждое последующее равно сумме двух ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая сортирует массив целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Напишите программу, которая сортирует массив ненулевых целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Задача: написать программу на Паскале, С (С++) или Бейсике. Входной файл: input. txt. Выходной файл: output. txt. Ограничение времени выполнения программы: 1 секунда на тест.
Ответы (1)
Даны два файла: input. txt и output. txt. В input. txt дана последовательность чисел: 1,6,11,16,21. В Output. txt отобразить размах ряда (т. е разность между наибольшим и наименьшим числом). Pascal
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)