Задать вопрос
14 марта, 16:43

Решить в паскале:

Написать программу решения квадратного уравнения

+1
Ответы (1)
  1. 14 марта, 20:09
    0
    Program QuadraticEquation;

    Var a, b, c, d, x1, x2:real;

    Begin

    Writeln ('vvedite a, b, c') ;

    Readln (a, b, c) ;

    If A=0 then

    Writeln ('algoritm ne primenim') ;

    D:=b*b-4*a*c;

    If D<0 then

    Writeln ('deystvit resheniy net') ;

    If D=0 then

    Begin

    x1:=-b / (2*a) ;

    Writeln ('x1=', x1) ;

    End

    Else

    Begin

    x1: = (-b+sqrt (D)) / (2*a) ;

    x2: = (-b-sqrt (D)) / (2*a) ;

    Writeln ('x1=', x1, 'x2=', x2) ;

    End;

    end.

    Держи!)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить в паскале: Написать программу решения квадратного уравнения ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы