Задать вопрос
12 мая, 19:56

Составить программу, которая запоминает массив а (1 ... 10) случайными числами от 1 о10 затем первый элемент меняет местами с максимальным элементом

+5
Ответы (1)
  1. 12 мая, 22:19
    0
    Var

    a: array [1 ... 10] of integer;

    i, max, s, x: integer;

    begin

    s:=1;

    randomize;

    for i : = 1 to 10 do

    begin

    a[i] : = random (10) + 1

    end;

    writeln (a) ;

    max : = a[1];

    for i : = 1 to 10 do

    begin

    if max < a[i] then begin

    max : = a[i];

    s : = i

    end;

    end;

    x : = a[1];

    a[1] : = a[s];

    a[s] : = x;

    writeln (a)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая запоминает массив а (1 ... 10) случайными числами от 1 о10 затем первый элемент меняет местами с максимальным ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу, которая заполняет массив a[1 ... 10] случайными числами в диапазоне от 0 до 10, затем первый элемент меняет местами с максимальным элементом. Выведите на экран исходный и полученный массивы.
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)
A) Составьте программу, которая заполняет масcив a[10 ... 20] случайными целыми числами в диапазоне от 10 до 20, затем меняет местами первый и последний элементы. Выведите на экран исходный и полученный массивы.
Ответы (1)
составьте программу, которая заполняет массив случайными целыми числами в диапозоне от 1 до 100, затем меняет местами наименьший четный элемент с наибольшим нечетным элементом
Ответы (1)
Составьте программу, которая заполняет массив из 10 элементов случайными целыми числами в диапазоне от 1 до 10, а затем меняет последний и первый элемент местами и выыодит на экран исходный и полученный массив.
Ответы (1)