Задать вопрос
26 апреля, 14:39

Сколько элементов массива превышают среднее арифметическое значение максимального и минимального элементов?) на паскале

+4
Ответы (1)
  1. 26 апреля, 16:44
    0
    Var

    a:array[1 ... n] of integer;

    i, min, max, k:integer;

    mid:real;

    begin

    write ('Кол-во элементов массива: ') ;

    readln (n) ;

    for i:=1 to n do

    readln (a[i]) ;

    max:=0; k:=0;

    for i:=1 to n do

    if a[i]> max then max:=a[i];

    min:=max;

    for i:=1 to n do

    if a[i]
    mid: = (max+min) / 2

    for i:=1 to n do

    if a[i]>mid then k:=k+1;

    writeln (k,' чисел') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сколько элементов массива превышают среднее арифметическое значение максимального и минимального элементов?) на паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Помогите составить программу в Paskal! 1) Вычислите значение минимального элемента массива 2) Вычислите сумму минисального и максимального элементов 3) Выведите номер минимального элемента 4) Выведите номера максимальных элементов и их количество
Ответы (1)