Задать вопрос
26 июня, 17:08

Напишите программу в паскале, которая вводит двумерный массив целых чисел 5 на 10 элементов случайным образом и выводит его на экран

+4
Ответы (1)
  1. 26 июня, 18:53
    0
    Const n=5; m=10;

    var

    a:array[1 ... n, 1 ... m] of integer;

    i, j:integer;

    begin

    Randomize;

    writeln ('Исходный массив:') ;

    for i:=1 to n do

    begin

    for j:=1 to m do

    begin

    a[i, j]:=random (100) ;

    write (a[i, j]:4) ;

    end;

    writeln;

    end;

    end.

    Пример (массив 4*5) :

    Исходный массив:

    80 22 78 64 15

    21 34 96 84 12

    55 29 45 92 73

    35 60 63 9 17
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу в паскале, которая вводит двумерный массив целых чисел 5 на 10 элементов случайным образом и выводит его на экран ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)
доброго времени суток.) кто-нибудь может помочь? ибо я совсем не вывожу информатику. 1. Написать программу, которая вводит массив из N целых чисел и выводит на экран элементы с чётными номерами.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Напишите программу, которая вводит массив из N целых чисел и выводит на экран элементы, кратные числу K. Протестировать программу на следующих исходных данных: а) k=3 Массив: 2 6 - 9 4 5 12 - 15 б) k=4 Массив: 9 0 8 124 - 16 11 19
Ответы (1)