Задать вопрос
14 сентября, 03:27

Дан числовой ряд и некоторое малое число ε (например, ε=0,00001). Найти сумму тех членов ряда, модуль которых больше или равен заданному ε. Формула

+2
Ответы (1)
  1. 14 сентября, 07:16
    0
    Const eps=0.00001;

    var b, c:integer; a, s:real;

    begin

    s:=0;

    b:=1; c:=1;

    a:=1/b+1/c;

    while abs (a) >=eps do

    begin

    s:=s+a;

    b:=2*b; c:=c*3;

    a:=1/b+1/c;

    end;

    writeln ('s = ', s:8:5) ;

    end.

    Результат:

    s = 3.49998
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан числовой ряд и некоторое малое число ε (например, ε=0,00001). Найти сумму тех членов ряда, модуль которых больше или равен заданному ε. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать прогу на паскале! Дан числовой ряд и некоторое малое число e (например, e=0,00001). Найти сумму тех членов ряда, модуль которых больше или равен заданному e. Общий член ряда имеет вид: An=n! / (2n) !
Ответы (1)
А. Составьте подпрограмму-функцию, которая по заданному натуральному числу n вычислит сумму его цифр. б. Составьте алгоритм, подсчитывающий количество n-значных натуральных чисел, у каждого из которых сумма цифр равна заданному натуральному числу k.
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
Вывести все значения элементов заданной числовой последовательности. Входные данные: Выходные данные: Во входном потоке в первой строке записано единственное целое число N (0 < N < = 100) - число элементов числовой последовательности;
Ответы (1)
Задача! 1. Дан массив целых чисел, состоящий из 15 элементов. Найти: 1) сумму положительных элементов, значения которых меньше 102) вывести индексы тех элементов, значения которых кратны 3 и 5. 2.
Ответы (1)