Задать вопрос
20 марта, 09:22

Задача!

1. Дан массив целых чисел, состоящий из 15 элементов. Найти: 1) сумму положительных элементов, значения которых меньше 102) вывести индексы тех элементов, значения которых кратны 3 и 5.

2. Определить, есть ли пара соседних элементов с суммой, равной заданному числу.

+2
Ответы (1)
  1. 20 марта, 13:06
    0
    var a:array[1 ... 15]of integer;

    b:array[1 ... 15]of boolean;

    i, s:integer;

    begin

    for i:=1 to 15 do begin

    readln (a[i]) ;

    if a[i]<10 then s:=s+a[i];

    if (a[i] mod 3=0) and{or} (a[i] mod 5=0) then b[i]:=true;

    end;

    for i:=1 to 15 do if b[i]=true write (i,' ') ;

    writeln (s) ;

    end.

    var a:array[1 ... 15]of integer;

    i, k:integer; c:boolean;

    begin

    readln (k) ;

    for i:=1 to 15 do readln (a[i]) ;

    for i:=1 to 14 do if a[i]+a[i+1]=k then begin writeln ('est') ; c:=true; break; end;

    if c=false then writeln ('net') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача! 1. Дан массив целых чисел, состоящий из 15 элементов. Найти: 1) сумму положительных элементов, значения которых меньше 102) вывести ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Дан массив из n элементов. Необходимо определить, есть ли в данном массиве два соседних элемента, равных заданному числу k ? Если есть, то вывести индексы первой такой пары чисел.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Дан массив, состоящий из целых чисел. Напишите программу, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми знаками. Входные данные Сначала задано число N - количество элементов в массиве (1N10000).
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)