Задать вопрос
20 июня, 08:49

Пользователь вводит целое число. Определите ближайшее к нему число кратное 7 (больше введенного). Вывести ответ с соответствующими пояснениями.

+5
Ответы (1)
  1. 20 июня, 12:09
    0
    Var a, b:integer;

    begin

    write ('a = ') ;

    readln (a) ;

    b: = (a-a mod 7) div 7*7+7;

    writeln ('b = ', b) ;

    end.

    Пример:

    a = 15

    b = 21
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Пользователь вводит целое число. Определите ближайшее к нему число кратное 7 (больше введенного). Вывести ответ с соответствующими ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
Помогите с программой. Пользователь вводит с клавиатуры сумму, которая у него есть. Далее"садится за рулетку". Программа спрашивает, какая ставка и на что ставит. пользователь. Ставка идет на конкретное число (от 1 до 36).
Ответы (1)
Какое событие наступит после того, как: А) ученик встретит учителя Б) пользователь выберет команду меню В) пользователь выберет объект правой кнопкой мыши Г) пользователь включит компьютер Д) пользователь перетянет левый нижний угол окна
Ответы (1)