Задать вопрос
8 января, 05:03

В классе N учеников. Найти средний рост ученика в этом классе. (паскаль)

+2
Ответы (1)
  1. 8 января, 07:10
    0
    var s, i, n, k: integer;

    begin

    repeat

    write ('Введите кол-во учеников: ') ;

    read (n) ;

    until n>0;

    for i:=1 to n do

    begin write ('Введите рост ', i,' ученика: ') ;

    repeat read (k) ;

    until k>0;

    inc (s, k) ;

    end;

    write ('Средний рост = ', s/n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В классе N учеников. Найти средний рост ученика в этом классе. (паскаль) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помогите написать программу на Паскале Известен рост каждого ученика в классе. Рост мальчиков условно задан отрицательными числами. Определить средний рост мальчиков и средний рост девочек.
Ответы (1)
Program a2; var n, i, min, max, x:integer; begin Writeln ('Введите колицество человек в классе:') ; Readln (n) ; Writeln ('Введите рост 1 ученика:') ; readln (x) ; min:=x; max:=x; for i:=2 to n do begin Writeln ('Введите рост ', i,' ученика:') ;
Ответы (1)
Известен рост каждого ученика группы. Рост мальчиков задан отрицательными числами. Верно ли, что средний рост мальчиков не превышает рост девочек более чем на 10 см?
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)