Задать вопрос
27 декабря, 09:39

Дан массив из 45 целых чисел от 1 до 1000. Вычислить сумму всех двузначных элементов массива и произведение однозначных элементов.

+4
Ответы (1)
  1. 27 декабря, 11:54
    +1
    Var

    a:array [0 ... 44] of integer;

    sum: integer;

    pr: integer;

    st: string;

    begin

    sum:=0;

    pr:=1;

    for i:=0 to 44 do

    begin

    Readln ('a[', i,']=', a[i]) ;

    str (a[i], st) ;

    if length (st) = 2 then

    sum:=sum+a[i];

    if length (st) = 1 then

    pr : = pr*a[i];

    end;

    Writeln ('Сумма: ', sum,' Произведение: ', pr) ;

    Readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из 45 целых чисел от 1 до 1000. Вычислить сумму всех двузначных элементов массива и произведение однозначных элементов. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)