Задать вопрос
11 декабря, 11:04

Дана последовательность из N чисел. определить сумму трех наибольших чисел

+2
Ответы (1)
  1. 11 декабря, 14:17
    0
    Begin

    n1:=a[1]; n2:=n1; n3:=n2;

    for i:=2 to n do

    if (a[i]>n1) then begin

    n3:=n2; n2:=n1; n1:=a[i]

    end;

    writeln (n1+n2+n3)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность из N чисел. определить сумму трех наибольших чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана последовательность не более N ненулевых целых чисел, последним числом в последовательности является 0. Ввести эту последовательность в одномерный массив и вычислить хаpактеристики . Найти порядковые номера и сумму двух наибольших элементов.
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Это в Паскале. Первая задача: Дана последовательность чисел, оканчивающихся отрицательным числом. Найти среднее арифметическое введенных положительных чисел. И вторая: Дана последовательность чисел, количество которых заранее не известно.
Ответы (1)
Помогите с прогой на паскале Ввести последовательность случайным образом N=12. Упорядочить последовательность по убыванию и вывести на экран два наибольших четных и наименьших нечетных числа.
Ответы (1)
Дана последовательность чисел. найти дана последовательность чисел. найти минимальное и максимальное число и вычислить их среднее арифметическое. в паскале
Ответы (1)