Задать вопрос
7 июля, 23:15

Напишите программу вычисления суммы чисел кратных 5 из натурального ряда чисел от 1 до n, и произведение чисел кратных к 3 (for)

+2
Ответы (1)
  1. 8 июля, 00:03
    0
    var

    i, s, p : integer;

    begin

    write ('n=') ;

    readln (n) ;

    s:=0;

    p:=1;

    for i:=1 to n do

    begin

    if i mod 5=0 then s:=s+i;

    if i mod 3=0 then p:=p*i

    end;

    Writeln ('s=', s, ' p=', p)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу вычисления суммы чисел кратных 5 из натурального ряда чисел от 1 до n, и произведение чисел кратных к 3 (for) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Написать программу вычисления суммы кратных 5 из натурального ряда чисел от 1 до n, и произведение чисел кратных 3 (2 способа: for, while)
Ответы (1)
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)
Задача номер 1 напечатать сумму элементов кратных одновременно двум или трем числового ряда 3, 6, 9, 2, 12, 2, 24 и задача 2 составить программу вычисления числового ряда для известного числа ряда N. Y = (1-2/5) + (2+4/10) + (3-8/15) + (4+16/20) + ..
Ответы (1)
Информатика pascal abc Pascal ABC задача номер 9 напишите программу вычисления y в зависимости от значения х у=1/х при х
Ответы (1)