Задать вопрос
1 февраля, 20:51

Pascal

Программу с помощью Case нужно сделать, условия.

Пусть время суток обозначено номерами: 1 - утро, 2 - день, 3 - ве-

чер. Билет в кино на утренний сеанс стоит (детский - 25 р., взрос-

лый - 70 р.), на дневной сеанс (детский - 50 р., взрослый - 100 р.), а

на вечерний (детский - 70 р., взрослый - 100 р.). Какова выручка

кинотеатра в одно из время суток, если в кино пришло n детей и m

взрослых.

+1
Ответы (2)
  1. 1 февраля, 23:40
    0
    Var t, n, m, s:integer;

    begin

    write ('t (1,2,3) = ') ;

    readln (t) ;

    writeln ('n, m:') ;

    readln (n, m) ;

    case t of

    1: begin s:=25*n+70*m; writeln ('Утренняя выручка = ', s) ; end;

    2: begin s:=50*n+100*m; writeln ('Дневная выручка = ', s) ; end;

    3: begin s:=70*n+100*m; writeln ('Вечерняя выручка = ', s) ; end;

    else writeln ('Ошибка ввода') ;

    end;

    end.

    Пример:

    t (1,2,3) = 1

    n, m:

    10 5

    Утренняя выручка = 600
  2. 1 февраля, 23:44
    0
    Var

    k, m, n: byte;

    begin

    write ('Введите время суток: ') ;

    readln (k) ;

    write ('Детей: ') ;

    readln (n) ;

    write ('Взрослых: ') ;

    readln (m) ;

    case k of

    1: write ('Выручка кинотеатра: ', (n*25) + (m*70) 'руб') ;

    2: write ('Выручка кинотеатра: ', (n*50) + (m*100) 'руб') ;

    3: write ('Выручка кинотеатра: ', (n*75) + (m*100) 'руб') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal Программу с помощью Case нужно сделать, условия. Пусть время суток обозначено номерами: 1 - утро, 2 - день, 3 - ве- чер. Билет в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Учитель проверяет работы письменного экзамена. Изначально на его столе нет ни одной работы. Иногда приносят стопку работ с подряд идущими номерами, при этом номера работ увеличиваются от низа стопки к ее верху.
Ответы (1)
Билет на одну поездку в метро стоит 15 рублей, билет на 5 поездок стоит 70 рублей, билет на 10 поездок стоит 125 рублей, билет на 20 поездок стоит 230 рублей, билет на 60 поездок стоит 440 рублей. Пассажир планирует совершить n поездок.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)