Задать вопрос
17 июля, 16:37

Билет на одну поездку в метро стоит 15 рублей, билет на 5 поездок стоит 70 рублей, билет на 10 поездок стоит 125 рублей, билет на 20 поездок стоит 230 рублей, билет на 60 поездок стоит 440 рублей. Пассажир планирует совершить n поездок. Определите, сколько билетов каждого вида он должен приобрести, чтобы суммарное количество оплаченных поездок было не меньше n, а общая стоимость приобретенных билетов - минимальна.

Формат входных данных

Дано одно число n - количество поездок.

Формат выходных данных

Выведите пять целых чисел, равные необходимому количеству билетов на 1, на 5, на 10, на 20, на 60 поездок. Если для какого-то данного n существует несколько способов приобретения билетов одинаковой стоимости, необходимо вывести ту комбинацию билетов, которая дает большее число поездок.

+1
Ответы (1)
  1. 17 июля, 20:10
    0
    чем больше поездок тем дешевле билет, начинаем с максимального

    var

    n60, n20, n10, n5, n1, n: integer;

    begin

    readln (n) ;

    n60 : = n div 60;

    n : = n - n60 * 60;

    n20 : = n div 20;

    n : = n - n20 * 20;

    n10 : = n div 10;

    n : = n - n10 * 10;

    n5 : = n div 5;

    n1 : = n - n5 * 5;

    writeln (n1) ;

    writeln (n5) ;

    writeln (n10) ;

    writeln (n20) ;

    writeln (n60) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Билет на одну поездку в метро стоит 15 рублей, билет на 5 поездок стоит 70 рублей, билет на 10 поездок стоит 125 рублей, билет на 20 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N. Формат входных данных Задано единственное число N. Формат выходных данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.
Ответы (1)
Паскаль Формат входных данных Сначала задано число N - количество элементов в массиве (1N35). Далее через пробел записаны N чисел - элементы массива. Формат выходных данных Необходимо вывести значение наибольшего элемента в массиве.
Ответы (1)
По данному числу n вычислите сумму 2 (1-1/3+1/5-1/7 + ... + (-1) n / (2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000. Формат выходных данных: Необходимо вывести значение выражения
Ответы (1)
Напишите рекурсивную функцию подсчёта количества цифр в натуральном числе. Формат входных данных На вход ваша программа получает одно натуральное число n (1≤n≤216-11≤n≤216-1). Формат выходных данных Выведите одно число - количество цифр в числе n.
Ответы (2)
задается целое число N. нужно вывести количество четных делителей числа N. Формат входных данных Единственная строка входного файла содержит единственное целое число N (1
Ответы (1)