Задать вопрос
27 апреля, 05:53

Pascal Составить программу поиска трех значных чисел, сумма цифр которого равна N

+4
Ответы (1)
  1. 27 апреля, 06:11
    0
    Var

    i, n, s, k: integer;

    begin

    readln (n) ;

    for i : = 100 to 999 do

    begin

    s : = 0; k : = i;

    while k > 0 do

    begin

    s : = s + k mod 10;

    k : = k div 10;

    end;

    if s = n then

    writeln (i) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal Составить программу поиска трех значных чисел, сумма цифр которого равна N ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана последовательность натуральных 3-х значных чисел, за которой следует 0. Составить программу поиска в данной последовательности элемента, сумма цифр которого равна N Делать программу через цикл While
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1) вывести трехзначные числа сумма цифр которых простое число pascal. 2) Дана последовательность 5,9,13,17, ... Составте программу для определения числа слагаемых, сумма которых равна 324.
Ответы (1)