Задать вопрос
9 декабря, 22:04

Дана последовательность натуральных 3-х значных чисел, за которой следует 0. Составить программу поиска в данной последовательности элемента, сумма цифр которого равна N

Делать программу через цикл While

+1
Ответы (1)
  1. 9 декабря, 23:10
    0
    Var

    k: array[1 ... 100] of integer;

    a, N, i, c:integer;

    begin

    c:=0;

    i:=1;

    a:=999;

    write ('Введите N: ') ;

    readln (N) ;

    writeln ('Введите a: ') ;

    while a0 do beginr

    eadln (a) ;

    if (a>=100) and (a<=999) then begin

    if ((a div 100) + ((a div 10) mod 10) + (a mod 10)) = N then begin

    k[i]:=a;

    i:=i+1;

    c:=c+1;

    end;

    end;

    end;

    if c>0 then begin

    writeln ('Числа, сумма цифр которых равна ', N,':') ;

    for i: = 1 to c do

    writeln (k[i]) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность натуральных 3-х значных чисел, за которой следует 0. Составить программу поиска в данной последовательности ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
Дана последовательность целых чисел. Получить упорядоченную по невозрастанию последовательность, состоящую из членов данной последовательности, заключённых между первым и последним отрицательными членами данной последовательности.
Ответы (1)
Сколько раз будет выполнен этот цикл? i:=2; while i
Ответы (2)