Задать вопрос
19 октября, 10:40

В массиве из 15 чисел подсчитать сумму и количество положительных элементов. Помогите, программа на языке паскаля

+5
Ответы (2)
  1. 19 октября, 12:12
    0
    Program n1;

    var a: array [1 ... 15] of integer;

    S, k, i: integer;

    begin

    for i:=1 to 15 do readln (a[i]) ;

    S:=0;

    k:=1;

    for i:=1 to 15 do

    begin

    if (a[i]>0) then

    begin

    S:=S+a[i];

    k:=k+1;

    end;

    end;

    writeln (k) ;

    writeln (S) ;

    end.
  2. 19 октября, 13:47
    0
    Var

    a: array[1 ... 15] of integer;

    i, sum, count: integer;

    begin

    for i:=1 to 15 do

    readln (a[i]) ;

    sum : = 0; count : = 0;

    for i:=1 to 15 do

    if a[i] > 0 then

    begin

    sum : = sum + a[i];

    inc (count) ;

    end;

    writeln (sum, ' ', count) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В массиве из 15 чисел подсчитать сумму и количество положительных элементов. Помогите, программа на языке паскаля ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программы для паскаля для следующих задач: 1. В массиве из 10 элементов подсчитать количество нечетных элементов 2. Вычислить сумму квадратов элементов, больших 2. Массив состоит из 5 элементов действительного типа. 3. Даны два массива.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
Python Напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
1) Составить массив из 10 целых чисел, вывести его на экран и подсчитать количество элементов массива, значения которых не превышают трех 2) Составить массив из 10 целых чисел и вывести его на экран, подсчитать сумму отрицательных и положительных
Ответы (1)