Задать вопрос
27 января, 17:58

Дан массив из 10 целых чисел. Определите, сколько элементов этого массива имеют максимальное значение. Надо написать на Паскале, объяснить при этом всё, ещё и блок схему надо

+2
Ответы (2)
  1. 27 января, 18:11
    0
    Var m:array[1 ... 10] of integer; i, max, cnt:integer;

    begin

    max : = - 1000;

    write ('Massive: ') ;

    for i : = 1 to 10 do begin

    m[i] : = random (11) - 5;

    write (m[i],' ') ;

    if m[i] > max then begin inc (cnt) ; max : = m[i]; end;

    end;

    writeln;

    writeln ('Максимальное число: ', max) ;

    writeln ('Всего максимальных чисел: ', cnt) ;

    end.
  2. 27 января, 19:52
    0
    Var m:array[1 ... 10] of integer; i, max, cnt:integer;

    begin

    max : = - 1000;

    write ('Massive: ') ;

    for i : = 1 to 10 do begin

    m[i] : = random (11) - 5;

    write (m[i],' ') ;

    if m[i] > max then begin inc (cnt) ; max : = m[i]; end;

    end;

    writeln;

    writeln ('Максимальное число: ', max) ;

    writeln ('Всего максимальных чисел: ', cnt) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из 10 целых чисел. Определите, сколько элементов этого массива имеют максимальное значение. Надо написать на Паскале, объяснить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)