Задать вопрос
9 марта, 04:13

Найти максимальный среди всех элементов тех строк заданной матрицы, которые упорядочены (либо по возрастанию, либо по убыванию).

Составить программу в Pascal.

+4
Ответы (1)
  1. 9 марта, 05:34
    0
    При использовании random () упорядоченные строки получаются редко. Можете массив вводить с клавиатуры.

    const n=5; m=4;

    var

    a:array[1 ... n, 1 ... m] of integer;

    i, j, max:integer;

    b1, b2:boolean;

    begin

    Randomize;

    writeln ('Исходный массив:') ;

    for i:=1 to n do

    begin

    for j:=1 to m do

    begin

    a[i, j]:=random (100) ;

    write (a[i, j]:4) ;

    end;

    writeln;

    end;

    max:=-1000;

    for i:=1 to n do

    begin

    b1:=true; b2:=true;

    for j:=1 to m-1 do

    begin

    if a[i, j]
    if a[i, j]>a[i, j+1] then b2:=false;

    end;

    if b1 or b2 then

    for j:=1 to m do

    if a[i, j]>max then max:=a[i, j];

    end;

    if max-1000

    then writeln ('max = ', max)

    else writeln ('В массиве нет упорядоченных строк') ;

    end.

    Пример:

    45 34 88 53

    2 7 36 71

    48 57 28 42

    75 61 10 93

    15 3 61 54

    max = 71
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти максимальный среди всех элементов тех строк заданной матрицы, которые упорядочены (либо по возрастанию, либо по убыванию). Составить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
Задача на C++. Двумерный массив 5*5. Для каждой строки заданной матрицы определить и напечатать сумму элементов столбцов с чётными номерами. Для каждого столбца заданной матрицы найти и напечатать максимальный элемент.
Ответы (1)
Сортировка массивов по возрастанию и по убыванию. Массив задается от датчика случайных чисел random (). Сортировать один и тот же исходный массив и по убыванию и по возрастанию значений элементов.
Ответы (1)
Даны две квадратные матрицы А и В размером 3 х3. Требуется найти С=А х В. Составить программу нахождения числа строк матрицы А (N, N), сумма элементов у которых отрицательна. pascal abc
Ответы (1)
Составить и отладить программу обработки матрицы размерности n*n. Выполнить программу для n=4. Подсчитать сумму элементов матрицы стоящих над главной диагональю в Pascal
Ответы (1)