Задать вопрос
1 декабря, 11:16

Дан массив из n элементов целого типа. Определить количество элементов, кратных a

+1
Ответы (1)
  1. 1 декабря, 11:35
    0
    Const n=10;

    var ar:array[1 ... n] of integer;

    a, k, i:integer;

    begin

    Randomize;

    for i:=1 to n do

    begin

    ar[i]:=random (20) + 1;

    write (ar[i]:3) ;

    end;

    writeln;

    write ('a = ') ;

    readln (a) ;

    k:=0;

    for i:=1 to n do

    if ar[i] mod a = 0 then k:=k+1;

    writeln ('k = ', k) ;

    end.

    Пример:

    15 2 20 13 12 2 7 14 2 4

    a = 3

    k = 2
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из n элементов целого типа. Определить количество элементов, кратных a ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)