Задать вопрос
6 декабря, 07:36

Язык Pascal.

Пользователю дано два целых числа - a и b, при условии что a < b. Найти среднее арифметическое всех целых чисел в интервале [a; b].

+1
Ответы (1)
  1. 6 декабря, 11:34
    0
    Program s;

    var a, b, sum, i, col: integer;

    sr: real;

    begin

    read (a) ;

    read (b) ;

    sum:=0;

    col:=0;

    for i: = a to b do begin

    sum:=sum+i;

    col:=col+1;

    sr:=sum/col;

    end;

    write ('среднее арифметическое равно ', sr) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Язык Pascal. Пользователю дано два целых числа - a и b, при условии что a < b. Найти среднее арифметическое всех целых чисел в интервале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Пользователю дано два целых числа - a и b. Найти среднее арифметическое всех целых чисел в интервале [a; b].
Ответы (1)
1) Найти сумму нечетных чисел на интервале [-30; 40]. 2) Найти кол-во чисел на интервале [-50; 120], которые кратны 9. 3) Найти произведение чисел кратных 11 на интервале [-10; 20]. 4) Последовательно вводятся N чисел. Найти их произведение.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Вопрос №591394 (тип: C) Даны два целых числа a и b. Напишите программу, которая находит среднее арифметическое квадратов всех целых чисел от a до b Входные данные: В первой строке вводятся два целых числа a и b (a
Ответы (1)