Задать вопрос
15 февраля, 11:57

Pabc. Дана матрица A (5,6). Составить массив, содержащий минимальные элементы каждой строки.

+1
Ответы (2)
  1. 15 февраля, 13:09
    0
    Const m=5; n=6;

    var

    a:array[1 ... m, 1 ... n] of integer;

    b:array[1 ... m] of integer;

    i, j, min:integer;

    begin

    Randomize;

    writeln ('Исходный массив:') ;

    for i:=1 to m do

    begin

    for j:=1 to n do

    begin

    a[i, j]:=random (50) ;

    write (a[i, j]:4) ;

    end;

    writeln;

    end;

    for i:=1 to m do

    begin

    min:=a[i, 1];

    for j:=2 to n do

    if a[i, j]
    b[i]:=min;

    end;

    writeln ('Полученный массив:') ;

    for i:=1 to m do write (b[i]:4) ;

    writeln;

    end.

    Пример:

    Исходный массив:

    44 30 35 16 47 3

    30 15 23 40 15 46

    46 11 2 3 16 40

    19 17 8 22 10 25

    41 23 9 47 7 36

    Полученный массив:

    3 15 2 8 7
  2. 15 февраля, 14:51
    0
    Var a: array [1 ... 5, 1 ... 6] of real;

    b: array [1 ... 5] of real;

    i, j: integer;

    begin for i:=1 to 5 do

    begin read (a[i, 1]) ;

    b[i]:=a[i, 1];

    for j:=2 to 6 do

    begin read (a[i, j]) ; {ввод элементов массива в цикле с параметром}

    if (b[i]>a[i, j]) then b[i]:=a[i, j];

    end;

    writeln; {для перехода на новую строку}

    end;

    for i:=1 to 5 do

    write (b[i], ' ') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pabc. Дана матрица A (5,6). Составить массив, содержащий минимальные элементы каждой строки. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного. 2) дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов.
Ответы (1)
Задать массив из n элементов. Значения вести с клавиатуры. Написать программу, уменьшающую все элементы массива на единицу. Вывести на экран массив дважды; сначала исходный массив (в строку), а затем с новой строки - полученный массив.
Ответы (1)
Дана матрица размерностью nxn найти Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы.
Ответы (1)
Помогите написать программу на VisualBasic! Дана матрица Y (5,5) (элементы матрицы выбрать самостоятельно). Вы- числить элементы новой матрицы Z (5,5) по правилу: zij = yij / ki, где ki - количе- ство положительных элементов i-той строки.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)