Задать вопрос
2 октября, 14:40

Pascal:

Дан натуральный отрезок чисел [A, B]. Найти те числа этого отрезка, которые при делении на данное число K, дают в остатке число 4.

+4
Ответы (1)
  1. 2 октября, 16:16
    0
    Остаток при делении числа n на k есть результат операции n mod k

    var

    a, b, i, k:integer;

    begin

    Write ('Укажите границы интервала [A; B]: ') ; Read (a, b) ;

    Write ('Задайте число k: ') ; Read (k) ;

    Write ('Отобранные числа: ') ;

    for i:=a to b do

    if i mod k = 4 then Write (i,' ')

    end.

    Пример

    Укажите границы интервала [A; B]: 8 27

    Задайте число k: 5

    Отобранные числа: 9 14 19 24
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal: Дан натуральный отрезок чисел [A, B]. Найти те числа этого отрезка, которые при делении на данное число K, дают в остатке число 4. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу поиска трехзначных чисел которые при делении на 43 дают в остатке 41 а при делении на 47 дают в остатке 43
Ответы (1)
Написать программу в python: найдите все пятизначные числа, которые при делении на 133 дают в остатке 125, а при делении на 134 дают в остатке 111.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Паскаль найдите все пятизначные числа которые делении на 133 дают в остатке 125 а при делении на 134 в остатке 111
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)