Задать вопрос
14 октября, 23:56

Аx^2+Вx+С=0

Написать программу нахождения действительных корней этого уравнения на Pascal

+1
Ответы (1)
  1. 15 октября, 00:52
    0
    Program z1;

    Uses CRT;

    Var a, b, c, d, x1, x1: real;

    Begin

    Clrscr;

    Write ('введите a, b, c') ; readln (a, b, c) ;

    D:=b*b-4*a*c;

    If d>=0 then

    Begin

    X1: = (-b+sqrt (d)) / (2*a) ;

    Х2: = (-b-sqrt (d)) / (2*a) ;

    Writeln ('x1=', x1' x2=', x2) ;

    END;

    Else writeln ('действительных корней нет') ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Аx^2+Вx+С=0 Написать программу нахождения действительных корней этого уравнения на Pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)