Задать вопрос
29 мая, 08:58

В однородном массиве, состоящем из N вещественных элементов найти максимальный по модулю массив

+5
Ответы (1)
  1. 29 мая, 12:29
    0
    Uses crt;

    var a:array[1 ... 99] of real;

    i, j, n:integer;

    max:real;

    begin

    write ('Введите n: ') ;

    readln (n) ;

    writeln ('Исходный массив: ') ;

    for i:=1 to n do begin

    a[i]:=random (99 - (-99) + 1) - 99;

    write (a[i]:5) ;

    end;

    writeln;

    max:=-5;

    for i:=1 to n do begin

    if abs (a[i]) >max then begin max:=abs (a[i]) ; j:=i; end;

    end;

    writeln ('Максимальное по модулю число равно ', a[j]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В однородном массиве, состоящем из N вещественных элементов найти максимальный по модулю массив ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В одномерном массиве, состоящем из n вещественных элементов, вычислить: 1) Максимальный по модулю элемент массива 2) Сумму элементов массива, расположенных между первым и вторым положительными элементами.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
В одномерном массиве, вводимом с клавиатуры и состоящем из 10 вещественных элементов, вычислить: 1) номер максимального по модулю элемента массива; 2) сумму элементов массива, расположенных после первого положительного элемента.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)