Задать вопрос
20 августа, 04:38

Решить задачу в паскаль с помощью функций. Даны 3 равносторонних треугольников со сторонами a, b, c. Напечатать номер треугольника с наибольшей площадью. Вычисление площадей организовать с

помощью функций, воспользовавшись формулой Герона.

+3
Ответы (1)
  1. 20 августа, 04:58
    0
    Function ST (a, b, c:real) : real;

    var

    p:real;

    begin

    p: = (a+b+c) / 2;

    ST:=sqrt (p * (p-a) * (p-b) * (p-c))

    end;

    var

    a, s:array[1 ... 3] of real;

    i, k:integer;

    begin

    Write ('Введите длину стороны каждого треугольника: ') ;

    for i:=1 to 3 do begin

    Read (a[i]) ;

    s[i]:=ST (a[i], a[i], a[i]) ;

    end;

    if s[1]>s[2] then k:=1 else k:=2;

    if s[3]>s[k] then k:=3;

    Writeln ('Треугольник номер ', k,' имеет наибольшую площадь')

    end.

    Пример

    Введите длину стороны каждого треугольника: 6 7.3 4.18

    Треугольник номер 2 имеет наибольшую площадь
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить задачу в паскаль с помощью функций. Даны 3 равносторонних треугольников со сторонами a, b, c. Напечатать номер треугольника с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Даны 3 равносторонних треугольников со сторонами a, b, c. Напечатать номер треугольника с наибольшей площадью. Вычисление площадей организовать с помощью функций, воспользовавшись формулой Герона.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Даны координаты четырех точек х1, у1, х2, у2, х3, у3, х4 и у4 найти наибольшую из площадей треугольников, вершины которых находятся в заданных точках (формула Герона, максимум из 2-ух чисел).
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Помогите решить эту задачу в паскале! Для двух треугольников с катетами а, b, с, d. Найти сумму площадей треугольников. (Вычисление площади оформить в виде под программы-функция или процедура).
Ответы (1)