Задать вопрос
24 февраля, 10:52

Напишите функцию, вычисляющую сумму четвертых степеней цифр этого числа. Используя эту функцию, напишите программу, выводящую все числа, равные сумме четвертых степеней своих цифр.

+4
Ответы (1)
  1. 24 февраля, 11:04
    0
    Сумма 4-х степеней N-значного числа не превосходит N * 9^4 < 10000N.

    С другой стороны, N-значное число больше 10^ (N-2).

    Для того, чтобы одно было равно другому, должно выполниться

    10^ (N - 2) < 10000N, 10^N < N * 10^6.

    Так может быть, только если N < 7, поэтому ищем числа среди 1 ... 999999.

    Код:

    function Sum4Deg (n: integer) : integer;

    var

    s: integer;

    begin

    s : = 0;

    repeat

    s : = s + sqr (sqr (n mod 10)) ;

    n : = n div 10;

    until n = 0;

    Sum4Deg : = s;

    end;

    var

    i: integer;

    begin

    for i : = 1 to 999999 do

    if i = Sum4Deg (i) then

    writeln (i) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите функцию, вычисляющую сумму четвертых степеней цифр этого числа. Используя эту функцию, напишите программу, выводящую все числа, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Умоляю, помогите с Паскалем 1. Пользователь вводит неотрицательное однозначное число A. Написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом A, вычисляющую в случае ввода 2 - площадь квадрата со стороной A, вычисляющую в
Ответы (1)
Напишите функцию, вычисляющую длину отрезка по координатам его концов. С помощью этой функции напишите программу на Pascal ABC, вычисляющую периметр треугольника по координатам его вершин
Ответы (1)
1. написать программу, вычисляющую значение функции y=x-24 2. написать программу, вычисляющую значение функции (y=f (x)) y=x-2, если x>0, y=0, если x=0, y=x*x, если x
Ответы (1)