Задать вопрос
23 августа, 13:52

Найти в строке указанную подстроку и заменить ее на новую. ее на новую. Строку, ее подстроку для замены и новую подстроку вводит пользователь.

+3
Ответы (1)
  1. 23 августа, 15:50
    0
    Var s, ss, s2:string;

    i:longint;

    Begin

    write ('String: ') ;

    readln (s) ;

    write ('Substring: ') ;

    readln (ss) ;

    Write ('Replace with: ') ;

    readln (s2) ;

    i:=pos (ss, s) ;

    delete (s, i, length (ss)) ;

    insert (s2, s, i) ;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти в строке указанную подстроку и заменить ее на новую. ее на новую. Строку, ее подстроку для замены и новую подстроку вводит ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Какое событие наступит после того, как: А) ученик встретит учителя Б) пользователь выберет команду меню В) пользователь выберет объект правой кнопкой мыши Г) пользователь включит компьютер Д) пользователь перетянет левый нижний угол окна
Ответы (1)
Помогите с программой. Пользователь вводит с клавиатуры сумму, которая у него есть. Далее"садится за рулетку". Программа спрашивает, какая ставка и на что ставит. пользователь. Ставка идет на конкретное число (от 1 до 36).
Ответы (1)
Пользователь клавиатуры вводит в минуту 60 знаков. Какое количество текстовой информации вводит этот пользователь за 5 минут в кодировке Unicode?
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)