Задать вопрос
2 декабря, 01:40

Пользователь вводит четыре числа. Найдите наибольшее четное число среди них. Если оно не существует, выведите фразу "not found". Сделать в паскаль

+2
Ответы (2)
  1. 2 декабря, 02:15
    0
    Var

    a: array[1 ... 4] of integer;

    i, max: integer;

    begin

    for i : = 1 to 4 do

    readln (a[i]) ;

    max : = a[1];

    for i : = 1 to 4 do

    if (a[i] mod 2 = 0) and (a[i] > = max) then

    max : = a[i];

    if max mod 2 = 0 then

    writeln (max)

    else

    writeln ('not found') ;

    end.
  2. 2 декабря, 05:20
    0
    Var a:array[1 ... 4] of integer;

    i, max:integer;

    b:boolean;

    begin

    b:=false;

    for i:=1 to 4 do

    read (a[i]) ;

    max:=a[1];

    for i:=1 to 4 do

    if (not odd (a[i])) and (a[i]>=max) then begin

    max:=a[i];

    b:=true;

    end;

    if b then write ('', max) else write ('not found') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Пользователь вводит четыре числа. Найдите наибольшее четное число среди них. Если оно не существует, выведите фразу "not found". Сделать в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу в Паскале 1. Выведите на экран 10 раз фразу "You are welcome!" 2. Выведите на экран n раз фразу "Silence is golden". Число n вводит пользователь.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
1. В языке PHP создайте генератор случайного числа от 1 до 10. Выведите результат выполнения на экран любым способом. 2. Если полученное случайное число четное, выведите на экран слово "четное", иначе выведите на экран слово "нечетное". 3.
Ответы (1)
Помогите с программой. Пользователь вводит с клавиатуры сумму, которая у него есть. Далее"садится за рулетку". Программа спрашивает, какая ставка и на что ставит. пользователь. Ставка идет на конкретное число (от 1 до 36).
Ответы (1)