Задать вопрос
24 августа, 21:35

Составить программу, печатающую все простые числа, не превосходящие данного числа.

паскаль абс

+5
Ответы (1)
  1. 25 августа, 00:25
    0
    Program Prostoe;

    Uses

    Crt;

    Var

    i, {возможный делитель}

    Number : integer; {исследуемое число}

    Begin

    ClrScr;

    writeln (‘Какое число должно быть проверено? ‘) ;

    read (Number) ;

    i : = 1;

    repeat

    i : = i+1;

    until Number mod i = 0;

    if Number=i

    then

    writeln (Number,’ является простым‘)

    else

    writeln (Number,’ делится на ‘, i) ;

    readln;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, печатающую все простые числа, не превосходящие данного числа. паскаль абс ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике