Задать вопрос
22 декабря, 05:02

Паскаль абс написать программу вычисления произведения положительных элементов третьей строки двумерного массива целых чисел паскаль абс

+1
Ответы (1)
  1. 22 декабря, 08:51
    0
    Const

    m=10;

    n=8;

    var

    a:array[1 ... m, 1 ... n] of integer;

    i, j:integer;

    p:double;

    begin

    Randomize;

    Writeln ('Исходный массив') ;

    for i:=1 to m do

    begin

    for j:=1 to n do

    begin

    a[i, j]:=Random (101) - 50;

    Write (a[i, j]:4) ;

    end;

    Writeln

    end;

    p:=1;

    for j:=1 to n do

    if a[3, j]>0 then p:=p*a[3, j];

    Writeln ('Искомое произведение: ', p)

    end.

    Тестовое решение:

    Исходный массив

    35 30 35 - 25 - 50 8 - 20 47

    -34 - 26 - 7 34 - 9 - 31 10 - 46

    -17 - 21 27 8 27 41 35 - 48

    30 - 44 25 48 30 - 20 10 - 6

    -3 - 10 45 - 33 3 - 38 - 11 - 8

    47 - 25 - 27 - 7 2 - 20 - 4 - 48

    -38 32 - 29 - 41 31 16 46 44

    45 33 - 4 45 34 - 18 - 33 37

    15 49 - 14 - 49 - 25 - 8 1 - 30

    41 - 15 11 1 17 - 8 0 - 1

    Искомое произведение: 8368920
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль абс написать программу вычисления произведения положительных элементов третьей строки двумерного массива целых чисел паскаль абс ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль, составьте программу для двумерного массива: Найти произведение отрицательных элементов указанной строки двумерного массива размером 4*5 целых чисел.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)