Задать вопрос
24 апреля, 14:10

Подсчитать количество элементов массива, кратных 3 и больших 50 в массиве А {1 ... 10}

+4
Ответы (1)
  1. 24 апреля, 14:37
    0
    Var

    a:array[1 ... 10] of integer;

    i, k:integer;

    begin

    for i:=1 to 10 do begin

    write (i,'-й элемент: ') ;

    readln (a[i]) ;

    end;

    k:=0;

    for i:=1 to 10 do

    if a[i]>50 and a[i] mod 3 = 0 then

    k:=k+1;

    writeln (k,' чисел') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Подсчитать количество элементов массива, кратных 3 и больших 50 в массиве А {1 ... 10} ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
Дан целочисленный массив из 7 элементов: 1) подсчитать произведение элементов массива кратных 5 и кратных 3. 2) подсчитать среднее значение четных элементов массива.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)