Задать вопрос
8 сентября, 13:37

Дан двумерный массив N*N элементов. Обнулите первый минимальный элемент в каждом столбце.

Формат ввода:

N (N<=10)

a[1,1] a[1,2] ... a[1, N]

a[2,1] a[2,2] ... a[2, N]

...

a[N, 1] a[N, 2] ... a[N, N]

Пример ввода:

5

3 4 1 3 8

2 5 6 6 5

1 3 6 1 4

3 5 1 7 2

1 2 3 2 1

Формат вывода:

b[1,1] b[1,2] ... b[1, N]

b[2,1] b[2,2] ... b[2, N]

...

b[N, 1] b[N, 2] ... b[N, N]

Пример вывода:

3 4 0 3 8

2 5 6 6 5

0 3 6 0 4

3 5 1 7 2

1 0 3 2 0

+2
Ответы (1)
  1. 8 сентября, 14:06
    0
    Var i, j, im, jm:byte;

    n:integer;

    a:array[1 ... 10,1 ... 10] of integer;

    min:integer;

    begin

    read (n) ;

    for i:=1 to n do

    for j:=1 to n do

    read (a[i, j]) ;

    for j:=1 to n do

    begin

    min:=a[1, j];

    for i:=1 to n do

    if a[i, j]
    min:=a[i, j];

    im:=i; jm:=j;

    end;

    if a[1, j]=min then a[1, j]:=0

    else a[im, jm]:=0;

    end;

    for i:=1 to n do

    begin

    writeln;

    for j:=1 to n do

    write (a[i, j]:2) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан двумерный массив N*N элементов. Обнулите первый минимальный элемент в каждом столбце. Формат ввода: N (N ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
2. Задать двумерный массив (4 х4) случайными значениями от 12 до 18 включительно. Вывести сумму значений элементов каждого столбца матрицы. 3. Задать двумерный массив (7 х7) случайными значениями от 12 до 18 включительно.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
С помощью Паскаля; Дан двумерный массив (4 столбца, 3 строки), заполненный случайным образом. Вывести массив и найти: а) количество отрицательных элеметов в 3 строке; б) сумму элементов всего массива; в) минимальный элемент в 1 столбце;
Ответы (1)